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BAB 1 
 

PENDAHULUAN 
 
 

 

A. Pengenalan Flash 
 

Macromedia Flash adalah software yang banyak dipakai oleh desainer web 

karena mempunyai kemampuan yang lebih unggul dalam menampilkan multimedia, 

gabungan antara grafis, animasi, suara, serta interaktifitas user. Macromedia Flash 

merupakan sebuah program aplikasi standar authoring tool profesional yang 

digunakan untuk membuat animasi vektor dan bitmap yang sangat menakjubkan 

untuk membuat suatu situs web yang interaktif, menarik dan dinamis. Software ini 

berbasis animasi vektor yang dapat digunakan untuk menghasilkan animasi web, 

presentasi, game, film, maupun CD interaktif, CD pembelajaran. 

Interaksi user dalam movie flash menggunakan Actionscript. Actionscript 

adalah suatu bahasa pemrograman yang berorientasi objek yang dipakai dalam 

Macromedia Flash. Macromedia Flash  menyediakan fasilitas-fasilitas yang lebih 

banyak dan menarik yang akan membantu, mempermudah user dalam mempelajari 

atau menggunakan software ini dibandingkan dengan Flash versi sebelumnya. 

Animasi-animasi dapat dibuat dengan lebih sederhana, cepat dan lebih menarik 

menggunakan Flash karena adanya kelebihan yang dimiliki oleh Flash. 
 

B. Area Kerja Macromedia Flash 
 

Macromedia Flash mempunyai area kerja yang terdiri dari enam bagian 

pokok yaitu : 
 

Menu 
 

Berisi kumpulan instruksi atau perintah-perintah yang digunakan dalam Flash. 

Terdiri dari menu File, Edit, View, Insert, Modify, Text, Control, Window, Help. 

Stage 
 

Stage adalah layer (document dalam word) yang akan digunakan meletakkan 

objek-objek dalam Flash. 
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Title Bar Time Line Menu Bar  
 
 

 

Tool  
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Gambar 1.1 Area Kerja Macromedia Flash 
 
 

Timeline 
 

Timeline berisi frame-frame yang berfungsi untuk mengontrol objek yang 

dibuat dalam stage atau layer yang akan dibuat animasinya. 
 

Toolbox 
 

Toolbox berisi tool-tool atau alat yang digunakan untuk membuat, 

menggambar, memilih, menulis, memanipulasi objek atau isi yang terdapat dalam 

stage (layer) dan timeline. Alat-alat yang terdapat dalam toolbox adalah : 

Arrow tool : memilih dan memindahkan object 
 

Subselect tool : memilih titik-titik pada suatu objek atau garis 
 

Line tool : membuat garis 
 

Lasso tool : memilih sebagian dari object atau bagian tertentu dari 
 

object 
 

Pen tool : menggambar garis-garis lurus maupun garis kurva 
 

Text tool : menulis teks 
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Oval tool : membuat lingkaran 
 

Rectange tool : membuat persegi maupun persegi panjang 
 

Pencil tool :  menggambar  garis-garis  bebas,  seperti  menggunakan 
 

pensil biasa 
 

Brush tool : berfungsi seperti kuas untuk mengecat mewarnai suatu 
 

object 
 

Fill Transform tool : mengatur ukuran, tengah, arah dari warna gradasi atau 
 

bidang suatu objek 
 

Free Transform tool : mengubah dan memodifikasi bentuk dari objek yang 
 

dibuat  bisa  berupa  memperbesar,  memperkecil  ukuran 
 

objek. 
 

Ink Bottle tool : menambah, memberi dan mengubah warna pada garis di 
 

pinggir suatu objek (Stroke) 
 

Paint bucket tool : menambah, memberi, mengubah warna pada bidang 
 

objek yang dibuat 
 

Eyedropper tool : mengidentifikasikan warna atau garis dala sauatu objek 
 

Eraser tool : menghapus area yang tidak diinginkan dari suatu objek 
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BAB 2 
 

OBJEK DALAM FLASH 
 
 

 

A. Dasar Objek 
 

Ketika menggambar objek dalam Flash seperti objek lingkaran, kotak, oval 

dll, secara otomatis Flash akan menyediakan dua unsur objek, yaitu Fill (bidang 

objek) dan Stroke (bingkai/pinggir objek). 

 

 

Fill (bidang)  Stroke 

    
 

Gambar 2. 1 Unsur Objek 
 

 

B. Memilih atau Menyeleksi Objek 
 

Objek dalam Flash terbagi dalam dua unsur yaitu Fill objek dan stroke objek.  
 
 
 
 
 
 
 
 
 

 

Gambar 2.2 Gambar 2.3 Gambar 2.4 Gambar 2.5 

Keterangan :     

Gambar 2.2 Objek Belum Diseleksi Gambar 2.4 Stroke Objek Terseleksi 
    

Gambar 2.3 Fill Objek Terseleksi Gambar 2.5 Fill dan Stroke Objek Terseleksi 
     

 

Untuk melakukan penyeleksian objek, dilakukan dengan menggunakan Arrow 

Tool yang terdapat dalam Tools Box, kemudian tinggal di klik fill atau stroke dari 

objekyang akan diseleksi. Untuk menyeleksi seluruh objek (fill dan stroke) double 

klik pada fill objek tersebut.Objek Terseleksi 
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C. Pengaturan Stroke dan Fill dalam Menggambar Objek 
 

Objek dalam Flash dapat digambarkan dalam satu unsur saja, yaitu fill saja 

ataupaun stroke saja. 

1. Klik Rectange tool. 
 

2. Atur warna dari fill dan strokenya melalui Color pada Toolbox 
 

3. Klik tombol Stroke Color, lalu klik tombol No Color. No Color ditandai dengan 

garis merah melintang pada tombol Stroke Color. 
 
 
 
 
 
 
 
 

No Color 
 
 

Gambar 2.6 Option Color ToolBox 
 

4.  Buat objek segi empat di stage.  
 
 
 
 
 

 

Gambar 2.7 Objek Tanpa Stroke 
 

5. Kebalikan dari langkah diatas, gambar objek segiempat tanpa fill, dengan klik 

tombol Fill Color pada toolbox dan pilih No Color. 
 
 
 
 

 

Gambar 2.8 Objek Tanpa Fill 

 

6. Dengan menggunakan Paint Bucket tool ubahlah warna dari objek yang anda 

buat. Klik Paint Bucket Tool. 

7. Atur warna melalui Toolbox bagian Color. 
 

8. Pilih warna pada tombol Fill Color dengan klik tanda segitiga hitam. Pilih salah 

satu warna yang ada. 
 

10. Klik pada objek segiempat yang akan diganti warnanya. 
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Gambar 2.9 Pallet Warna pada Fill Color 
 

 

D. Membuat Gradasi Warna 
 

Untuk membuat contoh suatu gradasi warna ikuti langkah berikut : 
 

1. Buatlah sebuah objek lingkaran pada stage. 
 

2. Buatlah lingkaran tersebut tanpa stroke. 
 

3. Seleksi objek lingkaran tersebut. 
 

4. Klik tanda segitiga pada Panel Color Mixer. Jika Panel Color Mixer belum ada 

klik menu Window > Color Mixer kemudian tempatkan di bagian panel (bagian 

kanan stage). 

5. Klik Fill Color, pilih warna hitam. 
 

6. Klik Fill Style pilih Radial. Lingkaran akan berubah menjadi gradasi putih-hitam 
 

7. Ubahlah gradasi putih-hitam menjadi gradasi hitam-putih. Klik Pointer Gradasi 

bagian kiri di Bar Gradasi kemudian klik Fill Color dan ganti warnanya menjadi 

hitam. 

8. Klik Pointer Gradasi bagian kanan lalu klik Fill Color ganti warnanya menjadi 

putih. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 2.10 Panel Color Mixer dengan Gradasi Radial Putih-Hitam 
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Gambar 2.11 Hasil Gradasi Warna 
 
 

E. Transformasi Objek 
 

Untuk mengubah skala objek, langkahnya dalah sebagai berikut : 
 

1. Buat objek segiempat di stage. 
 

2. Seleksi seluruh objek. 
 

3. Klik Free Transform tool pada toolbox 
 

4. Drag salah satu titik sudutnya. 
 

Skala objek juga dapat diubah dengan menggunakan Transfom Panel yang ada 

di bagian kanan layar (Jika Transform Panel belum ada klik Window > 

Transform. Pada Transform Panel masukan sebuah nilai 1 sampai 1000 untuk 

kolom lebar dan tinggi, kemudian tekan Enter. 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 2.12 Panel Transform 
 

F. Memutar dan Memiringkan Objek 
 

1. Seleksi seluruh objek 
 

2. Klik Free Transform Tool pada toolbox 
 

3. Klik option Rotate and Skew pada toolbox 
 

4. Drag salah satu titik sudut dari objek untuk memutar objek. 
 

5. Klik option Distort dan drag salah satu titik sudut untuk memiringkan objek 
 

6. Dengan menggunakan Transform Panel. Klik Rotate dan isikan nilainya untuk 

memutar objek. (Objek dapat diputar dengan Modify > Transform > Rotate 90
0
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CW atau 90
0
 CCW untuk memutar objek sebesar 900 searah jarum jam (CW) 

atau berlawanan jarum jam (CCW). 
 
 

Rotate and Skew Scale 
 

Distort Envelope 
 
 
 
 
 
 

 

Gambar 2.13 Option Free Transform Tool 
 

7. Klik Distort pada Transform Panel dan isikan nilainya untuk memiringkan objek. 
 

 

G. Menata Posisi Objek 
 

1. Seleksi atau pilih objek yang akan dirapikan. 
 

2. Klik Align Panel (Jika belum ada Klik Window > Align). 
 

3. Klik icon To Stage di Align Panel untuK merapikan objek relatif terhadap ukuran 

stage. 

4. Klik icon-icon yang ada di Align Panel pada perintah Align, Distribute, atau 

Amtch Size untuk merapikan objek yang sudah dipilih sesuai dengan kebutuhan. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 2.14 Align Panel 
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BAB 3 
 

PENGOLAHAN TEKS 
 

 

Teks digunakan untuk menerangkan atau menjelaskan sesuatu dalam bentuk 

tulisan, pembuatan judul, komponen animasi, keterangan-keterangan untuk movie 

interaktif. Teks merupakan bagian yang mempunyai perananl cukup besar dalam 

pembuatan animasi. Teks dapat dimanipulasi atau dimodifikasi seperti halnya objek 

dalam Flash sesuai dengan kebutuhan sehingga teks yang dihasilkan mempunyai 

banyak variasi. 

Teks dalam Flash ditulis dengan memggunakan bantuan Text Tool pada 

Toolbox. Teks yang dihasilkan dapat di setting dengan menggunakan Propeties Panel. 

Propeties Panels untuk teks berisi menu atau atribut-atribut untuk membuat dan 

mengedit suatu teks. 

   Bold Style 

   Italic Style 
  Text (fill) color Change Direction of Text 

Instance Name Char Spacing Font Size Rotation 

Text Type Font Auto Kern Aligment 
  

 
 
 
 
 
 
 
 
 
 
 

 

Weight-Height Line type Selectable  Border Variable Edit Format 
X-Y Location   Option 

  
Render Text as HTML 

Edit Char 
 

URL Link Option   
 

Target 
 

 

Gambar 3.1 Properties Panels 
 

 

Flash  mempunyai tiga tipe teks yang masing-masing mempunyai fungsi yang 

berbeda. Tipe teks tersebut adalah sebagai berikut : 
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1. Static Text adalah jenis teks yang mempunyai karakter-karakter seperti teks biasa 

pada umumnya. 

2. Dynamic Text adalah jenis teks yang dapat menampilkan sifat teks yang dinamis 

dan bisa dikontrol, contohnya skor pertandingan olah raga yang yang dapat berganti 

sesuai dengan perolehan nilai dari pertandingan, nilai kurs mata uang dalam bursa 

efek, dll. 

3. Input Text adalah jenis teks yang dapat diisi oleh pengguna atau user dalam 

sebuah form isian atau Input Text digunakan untuk menerima berbagai input dari 

user. 

Teks yang ditulis atau dibuat dalam Flash orientasi dapat diubah sesuai 
 

dengan kebutuhan. Orientasi teks dalam flash ada tiga macam, yaitu : 
 

1. Horizontal, digunakan untuk membuat teks yang mengalir dari kiri ke kanan secara 

horisontal seperti penulisan teks pada umumnya ( setting default). 

2. Vertical Left-to-Right, digunakan untuk membuat teks yang mengalir ke bawah 

secara vertikal dari kiri ke kanan. 

3. Vertical Right-to-Left, digunakan untuk membuat teks yang mengalir ke bawah dari 

kanan ke kiri. 

Ikuti langkah-langkah berikut untuk membuat sebuah teks : 
 

1. Buka file flash baru. 
 

2. Klik Text Tool pada Toolbox. 
 

3. Klik di sembarang tempat pada stage, tuliskan kalimat “Komputer Multimedia” 

dengan ketentuan jenis huruf Arial, ukuran 16, bold. 

4. Aturlah orientasi teksnya menjadi, Horizontal, Vertical Left – to – Right, Vertical 
 

Right-to – Left.  
 
 
 
 
 
 
 
 
 
 
 
 

 

Vertical Left-to-Right Horizontal Vertical Right-to-Left 
 
 

Gambar 3.2 Orientasi Teks 
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BAB 4 
 

SIMBOL INSTANCE DAN LIBRARY 
 

 

A. Membuat Simbol 
 

1. Pastikan tidak ada objek yang terseleksi pada stage. 
 

2. Klik menu Insert > New Symbol. 
 

3. Akan tampil kotak dialog Create New Symbol. Tentukan salah satu behavior 

yang diinginkan. Pada kotak Name dapat diisikan nama untuk simbol yang 

dibuat, jika tidak diberi nama maka secara default komputer akan memberi nama 

simbol tersebut. Kemudian klik OK. 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 4.1 Kotak Create New Symbol 
 

4. Simbol yang baru dibuat akan diletakkan dalam Library Panel, kemudian 

tampilan Stage akan berubah ke Mode Edit Simbol. 
 
 
 
 
 

 

Tombol Nama 
 
 
 

 

Titik  

Regristrasi 
 
 
 
 

 

Gambar 4.2 Tampilan Stage dalam Mode Edit Simbol 
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Nama  
 
 
 
 

 

Gambar 4.3 Library Panel 

 

5. Pada mode Edit simbol buatlah sebuah objek dengan bantuan tool-tool untuk 

menggambar yang ada pada Toolbox. 

6. Setelah simbol dibuat, klik tombol Back untuk kembali ke Scene 1 atau kembali 

ke stage utama. 

 

B. Mengubah atau Mengonversi Objek Menjadi Simbol 
 

Simbol dapat dibuat dengan mengonversi atau mengubah objek tersebut 

menjadi simbol. Langkah-langkah untuk mengonversi objek menjadi simbol adalah 

sebagai berikut : 

1. Pilih salah satu objek yang ada di stage untuk dikonversi menjadi simbol. Jika 

objek belum ada, buat objek pada stage dengan menggunakan tool untuk 

menggambar pada toolbox. Misal objek yang akan dikonversi menjadi simbol 

adalah sebuah lingkaran. 

2. Klik menu Insert > Convert to Symbol. Dapat juga dengan menekan F8 pada 

keyboard. 
 
 
 
 
 
 
 
 
 

 

Gambar 4.4 Konversi objek ke simbol 
 

3. Ketikkan nama untuk simbol tersebut pada kotak isian Name pada Convert to 

Symbol. 
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4. Tentukan jenis simbol tersebut dengan memilih opsi yang ada pada pilihan 

Behavior. 

5. Pilih opsi Registration, tentuan titik registrasi dari simbol yang dibuat dengan 

meng-klik pada salah satu kotak kecil dari sembilan kotak yang ada. 

6. Klik tombol OK. 
 

7. Objek telah menjadi simbol ditandai dengan tanda kotak yang mengelilingi objek 

pada stage dan simbol akan masuk pada Library Panel. 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 4.5 Hasil Convert to Symbol 

 

8. Untuk mengedit simbol atau masuk ke mode edit simbol double klik simbol pada 

stage atau double klik simbol pada Library panel. 

 

C. Membuat Instance 
 

Instance dapat dibuat dari simbol-simbol yang ada pada Library Panel. 
 

Langkah-langkahnya adalah sebagai berikut : 
 

1. Buka Library Panel. Jika belum ada klik menu Window > Library. 
 

2. Pilih salah satu simbol simbol yang ada pada Library Panel. 
 

3. Klik dan drag nama simbol atau simbolnya ke stage.  
 
 
 

 

Klik and drag 
 
 
 
 

 

Klik and drag 
 
 

 

Gambar 4.6 Membuat Instance dari Library Panel 
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BAB 5 
 

ANIMASI 
 
 

 

A. Membuat Animasi Motion Tween 
 

Animasi Motion Tween adalah animasi yang paling banyak digunakan dalam 

membuat suatu animasi Tween. Langkah-langkahnya adalah sebagai berikut. 

1. Buka sebuah movie flash baru. 
 

2. Klik Oval tool pada toolbox untuk mengambar sebuah lingkaran tanpa stroke, 

beri warna lingkaran tersebut dengan warna gradasi. 

3. Seleksi seluruh lingkaran. 
 

4. Klik menu Insert > Convert to Symbol untuk mengubah objek menjadi simbol 

atau tekan F8 pada keyboard. 

5. Beri nama simbol tersebut pada kotak dialog Convert to Symbol dengan 

mengetikkan nama pada kotak Name. 

6. Pilih Behavior Graphic dengan mengklik lingkaran di katak dialog, kemudian klik 

OK. 

7. Ganti nama Layer 1 menjadi Lingkaran dengan double klik layer 1 kemudian 

ketikkan nama layer. 
 
 
 
 
 
 
 
 
 

 

Gambar 5.1 Mengganti Nama Layer 
 

8. Klik frame 35 di kotak Timeline. 
 

9. Klik menu Insert > Keyframe atau klik kanan tombol mouse kemudian pilih 

Insert Keyframe. 
 
 
 
 
 
 
 
 
 

 

Gambar 5.2 Insert Keyframe 
 

14 



10. Masih di frame 35, klik Arrow tool pada Toolbox kemudian pilih lingkaran dan 

pindahkan ke bagian kanan layar ( tempat animasi berakhir). 

11. Klik frame 1 di Timeline, kemudian klik Properties panel pada bagian bawah 

layar. Pilihlah bagian Tween dan klik Motion atau klik frame 1 kemudian klik 

kanan tombol mouse dan pilih Create Motion Tween. 
 
 
 
 
 
 
 
 
 

 

Gambar 5.3 Create Motion Tween 
 

12. Klik Frame 35, Lingkaran akan berpindah ke bagian kanan layar. 
 

13. Lakukan Test Movie dengan menekan Ctrl+Enter pada keyboard. 
 

 

B. Membuat Animasi Motion Tween dengan Objek Mengikuti Alur (Path) 
 

1. Buat sebuah movie flash baru. 
 

2. Ganti nama layer menjadi objek. 
 

3. Buatlah sebuah objek lingkaran atau kotak dengan menggunakan Oval Tool 

atau Rectange Tool pada Toollbox. 

4. Ubahlah objek tersebut menjadi simbol dengan behavior Graphic. 
 

5. Klik frame 35 pada Timeline dan berilah sebuah Keyframe. 
 

6. Buat sebuah layer baru, beri nama layer ini dengan nama Lintasan, letakkan di 

bawah layer objek. 

7. Buatlah sebuah lintasan pada layer ini dengan menggunakan Pencil Tool pada 

Toolbox. 

8. Klik frame 1 Layer objek, dan pindahkan objek pada awal lintasan.  
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 5.4 Posisi Awal dan Akhir Objek 
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9. Klik frame 35 Layer Objek dan pindahkan objek pada akhir lintasan yang telah 

dibuat. 

10. Kembali ke frame 1, klik menu Insert > Create Motion Tween atau klik kanan 

mouse dan pilih Create Motion Tween. 

11. Klik kanan Layer Lintasan dan klik Guide, terdapat gambar palu pada Layer 

lintasan. 

12. Klik Layer Objek, tahan dan drag/geser layer objek sehingga berada di bawah 

Layer lintasan, gambar palu berubah pada Layer lintasan. 
 
 
 
 
 
 
 
 
 

 

Gambar 5.5 Layer Guide 
 

13. Lakukan test movie. 
 

 

C. Membuat Animasi Motion Shape 
 

Animasi motion shape untuk membuat animasi perubahan bentuk satu ke 

bentuk lainnya, misalnya bentu kotak ke bentuk lingkaran, teks menjadi lingkaran, 

manusia menjadi binatang , dll. 

1. Buatlah sebuah movie flash baru. 
 

2. Buatlah objek kotak di stage dengan Rectange tool. 
 

3. Klik Frame 35, lalu klik menu Insert > Blank Keyframe. 
 

4. Klik Text Tool, dan ketikkan kalimat MULTIMEDIA dengan font Arial ukuran 60 

Bold. 
 
 
 
 
 
 
 
 
 
 

 

Gambar 5.6 Insert Blank Kyframe 

5. Klik Modify > Break A Part sebanyak dua kali. 
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6. Klik frame 1, klik Properties dan pilih Shape pada bagian Tween . 
 

7. Lakukan test movie. 
 

 

D. Animasi Masking 
 

Animasi masking animasi yang berfungsi seperti topeng yang menutupi 

wajah. Animasi masking berguna untuk menutupi objek satu dengan objek lainnya, 

sehingga objek yang menutupi terlihat transparan. Misalkan kita ingin membuat 

objek tulisan yang akan terlihat jika tertutup oleh objek lain. 

1. Buat sebuah movie flash baru. 
 

2. Buat tulisan MULTIMEDIA dengan menggunkan Text Tool. 
 

3. Klik frame 50 lalu klik menu Insert > Keyframe. 
 

4. Klik menu Insert > Layer untuk membuat layer baru sehingga terdapat dua layer 

dalam timeline. 

5. Klik Layer 2 untuk berpindah dari Layer 1. 
 

6. Buat persegi panjang dengan Rectange Tool, persegi panjang dibuat di atas 

tulisan MULTIMEDIA. 

 
 
 
 
 

 

Gambar 5.7 Persegi panjang di atas teks 
 

7. Seleksi persegi panjang tersebut dan ubah menjadi simbol dengan behavior 

Graphic. 
 

8. Klik frame 25 Layer 2, kemudian klik Insert > Keyframe dan pindahkan persegi 

panjang di bawah tulisan. 

 
 
 
 
 

 

Gambar 5.8 Persegi panjang di bawah teks 
 

9.  Klik Frame 50 dan pindahkan persegi panjang kembali di atas tulisan. 
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10 . Klik frame 1, kemu dian klik Insert > Create Motion Tween atau klik kanan 

mouse d an pilih Cr eate Motio n Tween atau klik P roperties dan pada bagian 

Tween pilih Motion. 

 

11. Lakukan langkah 10 pada fram e 25. 
 

12 . Klik kana n Layer 2 dan pilih Ma sk.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 5.9 Animasi M ask Laye r 

2 13 . Test mov ie dengan menekan Ctrl + Enter. 
 
 
 
 
 
 
 
 
 
 

Gam bar 5.10 L ayer dalam Keadaan Mask 
 

E. A nimasi To mbol 
 

Tamb ol atau button dalam Falsh MX dapat dib eri animasi sehingga tombol 

ak an terlihat lebih menarik dan interaktif pa da waktu t ombol dite kan atau disentuh 

de ngan mou se pointer. 

1. Buka mov ie flash baru. 
 

2. Buatlah p ersegi pan jang dengan Rectange tool. Klik Rectange Tool dan atur 

sudut dari persegi panjang ters ebut dengan klik Ro und Rectange Radius pada 

bagian ba wah Toolb ox (prop erties). 
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Gam bar 5.11 R ound Recta nge Tool 
 

3. Atur sudut-sudut persegi p anjang dengan men gganti nilai pada Round 

Rectang e Radius sebesar 30 point. 
 
 
 
 
 
 
 
 
 

 

Gambar 5.1 R ectange Setting 
 

4.  Beri warna persegi p anjang de ngan warn gradasi, 
 

5. Klik Teks Tool dan ketikkan M ENU. Letak kan teks di atas pers egi panjang . 
 

6. Aturlah letak persegi panjang dan teks dengan Allig n Panel.  
 
 
 

 

Gambar .13 Tomb ol dan Teks 
 

7. Seleksi seluruh obj ek (persegi panjang dan teks) dengan dra g mouse sampai 

seluruh objek berad a dalam ra dius mouse drag atau klik Edit > Select All. 

8. Klik men u Insert > Convert to Symbol atau teka n F8, beri nama sim bol dan 

pilih Beh avior : Button. 

9.  Klik Edit > Edit Symbol untu k masuk ke menu Edit Symbol atau Doub le Klik 
 

simbol ter sebut. 
 

10 . Terdapat empat buah frame pada mode E dit Symbol, yaitu Up, Over, Dow n, Hit. 
 

 

Up : Keadaan tombol sta ndar. 
 

Over : Keadaan ketika mo use berada di atas to mbol atau elewati to mbol 
 

Down : Keadaan tombol ketika ditekan 
 

Hit : Penentu an area tom bol yang b isa diklik dengan mo use. 
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11. Klik frame Up kemudian beri Keyframe dengan I nsert > K eyframe a tau klik 

kanan mo use dan pilih Insert K eyframe. Pilih teksny a saja dan ganti warn anya. 
 

12 . Klik frame Over dan beri key frame. Klik persegi panjang da n ubahlah warna 

persegi panjang dan teksnya. 

13 . Klik  Fra me  Down  dan  berilah  Keyfr ame.  Ubah  warna  persegi  p anjang. 

Kemudia n pilih Teksnya da n ganti t ulisan sek aligus wa rnanya m enjadi 

DAFTAR. 
 

14 . Klik fram e Hit dan I nsert Keyf rame. 
 

15 . Klik menu Insert > Layer untuk menambah layer b aru. Klik Fr ame Hit dan beri 
 

Keyfram e. 
 

16 . Masih di Layer 2, klik Rectange tool d n buat kotak di stage dengan ukuran 

lebih bes ar dari tom bol. Atur letaknya dengan Align Panel. 
 
 
 

 

over down hit 
 

 

Gambar5.14 Keadaan Tombol Pa da Masing-Masing Fra me 
 

17 . Pindahkan posisi L ayer 2 di b awah laye r 1 dengan klik layer 2 dan d rag ke 
 

bawah sampai layer 1.  
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 5.15 Posisi Lay er 2 dan Ke adaan Frame-Frame Layer 2 
 

18 . Klik Scene 1 untuk k embali ke stage utam a. 
 

19 . Lakukan Test Movie. 
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BAB 6 
 

NAVIGASI 
 
 
 

 

A. Sistem Navigasi 
 

Latihan ini bertujuan untuk membuat sebuah tombol yang akan mengontrol 

frame untuk melompat ke frame yang diinginkan. Misalnya seperti halaman web, jika 

kita menekan tombol tertentu maka kita akan menuju ke halaman yang kita inginkan. 

Langkah-langkahnya adalah sebagai berikut : 
 

1. Klik menu Window > Common Libraries > Buttons. 
 

2. Double klik Oval Button. Kili and drag Oval Button Orange dan Oval Button 

Green ke stage. 

3. Buat layer baru diatas Layer 1. Pindah ke Layer 2, klik frame 1 dan klik 

Proerties Panels, pada bagian Frame ketikkan Frame Label-nya satu. 
 
 
 
 
 
 
 
 

 

Gambar 7.1 Properties Frame Label 
 

4. Klik frame 10 dan 20 Layer 2, masukkan Blank Keyframe. 
 

5. Klik frame 10, klik Properties Panels, ketikkan dua pada frame labelnya. 
 

6. Lakukan langkah 5 pada frame 20 Layer 2 dengan frame label tiga. 
 

7. Klik frame 25, klik kanan mouse dan Insert Frame, sehingga Timelinenya 

terlihat seperti di bawah ini. 
 
 
 
 
 
 
 
 

 

Gambar 7.2 Timeline dengan Frame Label 
 

8. Klik frame 1 Layer 2, buka Action Panels, klik Action Toolbox atau klik tanda ( 

+ ) di atas Script Pane, kemudian pilih Action > Movie Control > Stop. 
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9. Lakukan langkah 8 pada frame 10 dan 20. 
 

10. Pindah ke Layer 1, klik tombol hijau kemudian buka Action Panels. 
 

11. Pindah ke Normal Mode, klik Action > Movie Control > Goto. Isikan bagian 
 

Type : Frame Label, Frame : dua  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 7.3 Action goto Frame Label Dua 
 

12. Lakukan langkah 11 untuk tombol orange, isikan Type : Frame Label dan 
 

Frame : tiga. 
 

13. Berikan Blank Keyframe untuk frame 10 dan 20 Layer 1. 
 

14. Klik frame 10, klik Text tool, ketikkan “Anda berada di halaman dua”. 
 

15. Klik frame 20, klik Text tool ketikkan “Anda berada di halaman tiga.” 
 

16. Lakukan test movie. 
 

17. Klik salah satu tombol hijau atau orange. Perhatikan perubahannya. 
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BAB 7 
 

MEMBUAT CD INTERAKTIF 
 

 

CD Pembelajaran Interaktif dalam modul ini akan membahas materi Matematika, 

Pokok Bahasan Trapesium.Untuk memulai membuat CD Pembelajaran Interaktif, 

langkah-langkahnya adalah sebagai berikut : 

1. Membuat folder tersendiri untuk menyimpan file-file yang akan dibuat sehingga 

pengorganisasian filenya akan lebih mudah dilakukan. 

2. Buatlah folder dengan nama Trapesium. Folder ini digunakan untuk menyimpan file-

file depan dari cd interaktif. 

3. Buatlah folder TUTORIAL dan SIMULASI dalam folder Trapesium. Folder Tutorial 

dan Simulasi digunakan untuk menyimpan file-file materi dari CD Interaktif. 

Sehingga susunan folder akan tampak seperti Gambar 8.1 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.1. Folder 
 

 

Setelah semua file dalam CD pembelajaran interaktif ini di buat maka organisasi filenya 

terlihat seperti dalam Gambar 8.2 
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TRAPESIUM 
 
 

 
     

SIFAT 

 

LUAS 

 

LATIHAN 

  

DEFINISI 

 

SIMULASI TUTORIAL        
                      

                      
                

 
SIFAT 

   

   SIFAT             
                  
                    

                      

                   

   LUAS            LUAS    
                 

                    

                      

   
LATIHAN 

      

FOLDER 

   
            

                 
              

FILE 

   

   DEFINISI          
                        

Gambar 8.2. Organisasi File 
 

 

Berdasarkan Gambar 8.2 terdapat 3 folder, yaitu folder Trapesium (folder 

utama), folder Tutorial dan folder Simulasi. File Sifat, Luas, Latihan dan Definisi dalam 

folder Trapesium (folder utama) adalah file-file window (jendela) utama. 

Folder Tutorial berisi file Sifat, Luas, Latihan dan Definisi adalah file-file yang 

berisi materi yang akan dibahas. Folder simulasi yang berisi file Sifat dan Luas adalah 

file-file yang berisi animasi untuk memperjelas materi yang ada di folder Tutorial. Jadi 

walaupun nama filenya sama tetapi isinya berbeda dalam setiap folder. 

 

A. Halaman Utama Definisi 
 

1. Buka file movie flash Definisi yang ada di CD. 
 

2. Simpan dengan nama Definisi di folder Trapesium. 
 

3. Terdapat 4 buah layer, yaitu layer Mask, layer 3 (isi layer mask), layer tambahan 

dan layer Template. Jumlah frame yang digunakan dalam setiap layer adalah 

100 frame. 

4. Buat layer baru di atas layer Mask, beri nama layer Action. 
 

5. Klik frame 1 layer action. Buka action panel dan berikan script berikut 
 

Mouse.show(); 

fscommand("fullscreen", "true"); 
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loadMovieNum("Tutorial/Definisi.swf",1); 
 

6. Klik frame 100. Buka action panel dan berikan script stop ( ); 
 

7. Buat 4 buah layer baru di bawah layer 3. Beri nama layer-layer tersebut dengan 
 

nama Sifat, Latihan, Definisi, Luas. (Layer ini berdiri sendiri, tidak ikut dalam 

layer masking). 

8. Klik frame 30 layer Sifat. Beri keyframe/insert keyframe di frame ini (Klik Insert > 

Keyframe). 

9. Ulangi langkah 7 untuk layer Latihan, Definisi, dan layer Luas. 
 

10. Kembali ke layer sifat. Klik frame 30. 
 

11. Buka Library Panel (Windows > Library). Klik and drag button sifat (symbol) ke 

stage. 

12. Klik button sifat. Atur propertiesnya di properties panel dengan ketentuan W = 

119.0, H = 30.5, X =329.0, Y = 630.5 dan Color = Alpha = 30%. 
 

13. Klik frame 30 layer Latihan. Klik and drag button latihan ke stage. 
 

14. Klik button latihan. Atur propertiesnya di properties panel dengan ketentuan W = 

125.8, H = 75.0, X = 510.9, Y = 631.0 dan Color = Alpha = 30%. 

15. Klik frame 30 layer Definisi. Klik and drag button definisi ke stage. 
 

16. Klik button definisi. Atur propertiesnya di properties panel dengan ketentuan W 

= 83.3, H = 72.4, X = 435.2, Y = 632.6 dan Color = Alpha = 30%. 

17. Klik frame 30 layer Luas. Klik and drag button luas ke stage. 
 

18. Klik button Luas. Atur propertiesnya di properties panel dengan ketentuan W = 

118.0, H = 32.0, X =329.0, Y = 673.5 dan Color = Alpha = 30%. 

19. Klik frame 70 layer Sifat. Klik Insert > Insert Keyframe. 
 

20. Klik button Sifat dan ganti alphanya menjadi 100%. 
 

21. Klik frame 30 layer sifat. Klik Insert > Create Motion Tween. 
 

22. Ulangi langkah 19 sampai 21 untuk layer Latihan, Definisi, Luas. 
 

23. Buat layer baru dibawah layer template. Beri nama layer Jurusan. Klik frame 1 

layer jurusan dan klik and drag button jurusan dari library panel ke stage. 

24. Klik button jurusan. Buka Properties panel dan ubah behaviornya menjadi 

Graphic. 

25. Buat layer baru di bawah layer jurusan beri nama layer Musik. 
 

26. Klik frame 1.Klik and drag sound music1 dari library panel ke stage. 
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27. Buat layer baru dibawah layer music beri nama Exit. Klik frame 1 dan klik and 

drag button exit dari library panel ke stage. 

28. Klik button exit dan atur propertiesnya dengan ketentuan W = 131.0, H = 31.0, X 

= 782.0, Y = 63.0. 

29. Klik frame 70 layer sifat. Kemudian klik button sifat di stage. Buka action panel 

dan berikan script berikut : 
 

on (release) { 

loadMovieNum("Sifat.swf",0); 

} 
 

30. Lakukan langkah 29 untuk button Definisi, Latihan dan Luas dengan ActionScript 

sebagai berikut : 

Button Definisi 
 

on (release) { 

loadMovieNum("Definisi.swf",0); 

} 
 

Button Latihan 
 

on (release) { 

loadMovieNum("Latihan.swf",0)

; 

} 
 

Button Luas 
 

on (release) { 

loadMovieNum("Luas.swf",0); 

} 
 

31. Lakukan Test Movie, klik Control > Test Movie atau tekan Control + Enter. 
 

 

B. Halaman Utama Sifat 
 

1. Buka file movie flash Definisi. 
 

2. Klik File > Save As. Beri nama Sifat dan simpan di folder Trapesium, sama 

seperti file Definisi. 

3. Klik frame 1 layer Action. Ganti ActionScriptnya dengan 
 

Mouse.show(); 
 

fscommand("fullscreen", "true"); 
 

loadMovieNum("Tutorial/Sifat.swf",1); 
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4. Buat dua buah layer baru di bawah layer Action, beri nama layer tersebut 

Tutorial dan Simulasi. 

5. Klik frame 60 layer Tutorial, klik Insert > Keyframe. 
 

6. Buka Library Panel (tekan F11). Klik and drag button Tutorial ke stage. 
 

7. Atur propertiesnya di properties panel dengan ketentuan W = 139.8, H = 24.4, X 

= 161.1, Y = 599.8, color = alpha = 30%. 

8. Klik frame 70 tambahkan keyframe. Ubah Alpha = 100%. 
 

9. Klik frame antara frame 60 samapai 70, klik Insert > Create Motion Tween atau 

klik kanan tombol mouse dan pilih Create Motion Tween. 

10. Ulangi langkah 5 sampai 9 untuk layer Simulasi dengan properties button 

Simulasinya adalah W = 119.6, H = 20.9, X = 591.7, Y = 603.5. 

11. Klik button Tutorial di stage. Buka Action Panel dan tambahkan script berikut 
 

on (release) { 

loadMovieNum("Tutorial/Sifat.swf",1); 

} 
 

12. Klik button Simulasi di stage. Buka action panel dan tambahkan script berikut 
 

on (release) { 

loadMovieNum("Simulasi/Sifat.swf",1); 

} 
 

13. Lakukan test movie, tekan Ctrl + Enter. 
 

 

C. Halaman Utama Luas 
 

1. Buka file movie flash Sifat. 
 

2. Klik File > Save As, beri nama Luas dan simpan di folder Trapesium. 
 

3. Klik frame 1 layer Action dan ubah ActionScriptnya menjadi 
 

Mouse.show(); 
 

fscommand("fullscreen", "true"); 
 

loadMovieNum("Tutorial/Luas.swf",1); 
 

4. Klik button Tutorial dan ganti actionScriptnya menjadi 
 

on (release) { 

loadMovieNum("Tutorial/Luas.swf",1); 
 

} 
 

5. Klik button simulasi dan ganti ActionScriptnya menjadi 
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on (release) { 
 

loadMovieNum("Simulasi/Luas.swf",1); 
 

} 
 

6. Lakukan Test Movie 
 

 

D. Halaman Utama Latihan 
 

1. Buka file movie flash Luas. 
 

2. Klik File > Save As, beri nama Latihan dan simpan di folder Trapesium. 
 

3. Klik frame 1 layer action, ganti ActionScriptnya menjadi 
 

Mouse.show(); fscommand("fullscreen", 

"true"); 

loadMovieNum("Tutorial/Latihan.swf",1); 
 

4. Klik kanan layer Tutorial, pilih Delete Layer. 
 

5. Klik kanan layer Simulasi, pilih Delete Layer. 
 

6. Lakukan test movie 
 

 

E. Halaman Tutorial Definisi 
 

1. Buka file movie flash Definisi di folder Tutorial. Dalam file ini terdapat Layer 

action. Layer ini menggunakan 40 frame. Frame 30 sampai frame 40 di bagi 

menjadi dua buah frame number, yaitu frame number satu dan frame number 

dua 
 
 
 
 
 
 
 
 
 

 

Gambar 8.3 Layer Action 
 

2. Simpan file ini di folder Tutorial dengan nama Definisi. 
 

3. Buat layer baru di bawah layer action, beri nama materi. 
 

4. Buka Library panel. Klik and drag simbol Tulisan yang mempunyai behavior 

Graphic ke stage. Atur propertiesnya dengan ketentuan W = 602.8, H = 333.9, X 

= 286.1, Y = 227.7 
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Gambar 8.4. Library Panel 
 

5. Klik frame 8 layer Materi, tambahkan keyframe Insert > Keyframe. Atur 

propertiesnya W = 602.9, H = 333.9, X = 225.0, Y = 227.7. 

6. Kili frame 1, klik Insert > Create Motion Tween 
 

7. Klik frame 31 layer materi. Klik Insert > Blank Keyframe. 
 

8. Klik frame 35 layer materi, klik Insert > Keyframe. 
 

9. Buka Library panel, klik and drag simbol Hal dua ke stage dan atur 

propertiesnya W = 634.0, H = 310.4, X = 286.0, Y = 226.9. 

10. Klik frame 40 layer Materi, klik Insert > Keyframe. Atur propertiesnya menjadi W 

= 634.1, H = 310.4, X = 228.0, Y = 226.9. 

11. Klik frame 35, klik Insert > Create Motion Tween. 
 

12. Tambahkan layer baru di bawah layer materi beri nama “link”. 
 

13. Klik and darag button gel Right di library panel ke stage dan atrur propertiesnya 
 

W = 32.3, H = 31.1, X = 816.1, Y = 577.1. 
 

14. Klik button gel Right buka action panel dan berikan script berikut 
 

on (release) { 
 

gotoAndPlay("dua"); 
 

} 
 

15. Klik frame 35 layer link, klik Insert > Keyframe. Klik and drag button gel Left ke 

stage dan atur propertiesnya W = 32.3, H = 31.1, X = 780.3, Y = 577.0. 
 

29 



16. Klik button gel Left buka action panel dan berikan script berikut 
 

on (release) { 

gotoAndPlay("satu")

; 

} 
 

17. Tambahkan layer baru di bawah layer link, beri nama graph. Klik frame satu, 

buka Library panel, klik and drag button gel Left ke stage. Atur propertiesnya 
 

W = 32.3, H = 31.1, X = 780.0, Y = 577.5 color = Alpha 30% dan ganti 

behaviornya = Graphic. 
 

18. Klik frame 35, klik Insert > Keyframe. 
 

19. Klik and drag button gel Right ke stage dan atur propertiesnya W = 32.3, H = 

31.1, X = 815.7, Y = 578.1 color = Alpha 30% dan ganti behaviornya = 

Graphic. 

20. Lakukan Test Movie, Ctrl + Enter.  
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 8.5. Layer-layer File Definisi 
 

 

F. Halaman Tutorial Sifat 
 

1. Buka file Sifat di folder Tutorial. Dalam file ini sudah terdapat layer action yang 

menggunakan 74 frame. 

2. Buat layer baru di bawah layer action, beri nama layer materi. 
 

3. Klik and drag simbol Tulisan yang ada di Labrary Panel ke stage dan atur 

propertiesnya W = 575.6, H =350.1, X = 284.1, Y = 223.7. 

4. Klik frame 30, klik Insert > Keyframe, dan atur propertiesnya W = 575.6, H 

=350.1, X = 225.0, Y = 223.7. 

5. Klik File > Save. 
 

6. Lakukan Test Movie. 
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G. Halaman Tutorial Luas 
 

1. Buka file Definisi yang ada di folder Tutorial. 
 

2. Klik File > Save As, beri nama Luas. 
 

3. Klik kanan layer Materi, pilih Delete Layer. 
 

4. Buat Layer baru di bawah layer Action beri nama Luas. 
 

5. Buka Library panel. Klik and drag simbol Luas1 yang mempunyai behavior 

Graphic ke stage. Atur propertiesnya dengan ketentuan W = 592.9, H = 319.9, X 
 

= 284.1, Y = 219.7 
 

6. Klik frame 5 layer Luas, tambahkan keyframe Insert > Keyframe. Atur 

propertiesnya W = 592.9, H = 319.9, X = 225.0, Y = 219.7 

7. Klik frame 1, klik Insert > Create Motion Tween 
 

8. Klik frame 31 layer Luas. Klik Insert > Blank Keyframe. 
 

9. Klik frame 35 layer Luas, klik Insert > Keyframe. 
 

10. Buka Library panel, klik and drag simbol Luas2 dua ke stage dan atur 

propertiesnya W = 625.6, H = 300.2, X = 284.3, Y = 221.8. 

11. Klik frame 40 layer Materi, klik Insert > Keyframe. Atur propertiesnya menjadi W 
 

= 625.6, H = 300.2, X = 226.3, Y = 221.8. 
 

12. Klik frame 35, klik Insert > Create Motion Tween. 
 

13. Lakukan Test Movie. 
 

 

H. Halaman Tutorial Latihan 
 

1. Buka file movie flash latihan yang ada di folder Tutorial. 
 

2. Buat layer abru di bawah layer Action beri nama LatSoal. 
 

3. Buka Library Panel, klik and drag simbol LATSOAL ke stage, atur propertiesnya 
 

W = 151.8, H = 26.4, X = 614.0, Y = 200.1, Color = Alpha = 30%. 
 

4. Klik frame 5, klik Insert > Keyframe. Atur propertiesnya W = 151.8, H = 26.4, X 
 

= 436.1, Y = 199.9, Color = Alpha = 100%. 
 

5. Klik frame 1, klik Insert > Create Motion Tween. 
 

6. Klik frame 10, klik Insert > Blank Keyframe. 
 

7. Buat layer baru di bawah layer LatSoal, beri nama SOAL. 
 

8. Klik frame 5, klik Insert > Keyframe. 
 

9. Klik and drag simbol Pilih ke stage, atur propertiesnya W = 517.5, H = 39.5, X = 

197.0, Y = 270.9. 
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10. Klik and drag simbol soal1, trap 1, button pilihan ke stage dan atur posisinya 

sehingga terlihat seperti berikut 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.6. Soal 1 
 

11. Klik frame 5 layer Soal, buka Action panel dan masukkan script berikut 
 

correct="0"; 
 

stop(); 
 

12. Klik button pilihan 50, buka Action panel dan berikan script berikut 
 

on (release) { 
 

correct=Number(correct)+1; 
 

nextFrame(); 
 

} 
 

13. Untuk button yang lain berikan scipt berikut 
 

on (release) { 

nextFrame(); 
 

} 
 

14. Klik frame 5 layer Soal, klik Edit > Copy Frame. 
 

15. klik frame 6, klik Edit > Paste Frame. 
 

16. Buka Action panel dan ganti scriptnya 

menjadi stop(); 

17. Klik and drag simbol soal2 ke stage, dan atur posisi dan propertinya sehingga 

seperti Gambar 8.7 

18. Klik button pilihan 115, ganti scriptnya menjadi 
 

on (release) { 
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correct=Number(correct)+1; 
 

nextFrame(); 
 

} 
 

19. Untuk button pilihan yang lain berikan action script sebagai berikut 
 

on (release) { 

nextFrame(); 
 

}  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.7. Soal 2 
 

20. Klik frame 6, klik Edit > Copy Frame. 
 

21. Klik frame 7, klik Edit > Paste Frame. 
 

22. Klik and drag simbol soal3, Trap 2 ke stage. 
 

23. Atur properties simbol soal3 dan ganti opsi pilihan jawaban seperti gambar 8.8.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.8. Soal 3. 
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24. Klik button pilihan 132, buka Action panel dan berikan script berikut 
 

on (release) { 

correct=Number(correct)+1; 

nextFrame(); 
 

} 
 

25. Untuk button pilihan yang lain, berikan script berikut 
 

on (release) { 
 

nextFrame(); 
 

} 
 

26. Klik frame 7, klik Edit > Copy Frame. 
 

27. Klik frame 8, klik Edit > Paste Frame. 
 

28. Klik and drag simbol soal4, Trap 3 ke stage. 
 

29. Atur properties simbol soal4 dan ganti opsi pilihan jawaban seperti gambar 8.9.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Gambar 8.9. Soal 4 
 

30. Klik button pilihan 65, buka Action panel dan berikan script berikut 

on (release) { 

correct=Number(correct)+1; 
 

nextFrame(); 
 

} 
 

31. Untuk button pilihan yang lain, berikan script berikut 
 

on (release) { 

nextFrame(); 
 

} 
 

32. Klik frame 7, klik Edit > Copy Frame. 
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33. Klik frame 8, klik Edit > Paste Frame. 
 

34. Klik and drag simbol soal5, Trap 3 ke stage. 
 

35. Atur properties simbol soal5 dan ganti opsi pilihan jawaban seperti gambar 8.10.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.10. Soal 5 
 

36. Klik button pilihan 115, buka Action panel dan berikan script berikut 
 

on (release) { 

correct=Number(correct)+1; 

nextFrame(); 
 

} 
 

37. Untuk button pilihan yang lain, berikan script berikut 
 

on (release) { 
 

nextFrame(); 
 

} 
 

38. Klik frame 10, klik Insert > Key Frame. 
 

39. Klik and drag simbol hasil dan simbol Anda dari Library panel ke stage. Atur 

posisisnya seperti Gambar 8.11. 

40. Klik button Coba ke stage, atur posisinya seperti gambar 8.11. 
 

41. Klik Text Tool pada Toolbox. Buat teks dengan jenis Input Text disamping 

tulisan ANDA BENAR : 

Untuk membuat Input Text, setelah memilih Text Tool, buka Properties 

Panel dan ganti jenis teksnya menjadi Input Text. (pojok kiri atas) 
 

42. Klik Input Text, buka Properties panel, klik kotak Variabel dan ketikkan correct. 

(correct = nama variabel untuk Input Text). 

43. Buat Input Text lagi tempatkan di bawah Input Text yang pertama. 
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44. Buka Properties panel, klik kotak Variabel dan ketikkan comment.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.11. Frame Hasil 
 

45. Klik button COBA LAGI, buka Action panel, berikan script berikut 
 

on (release) { 

gotoAndPlay(5)

; 

} 
 

46. Klik frame 10 layer Soal, buka Action panel dan berikan scitp 

berikut stop(); 

if (Number(correct)==5){ 
 

comment = "PERTAHANKAN PRESTASIMU...."; 

}else if ((Number (correct)<=4) and (Number (correct)>=3)){ 
 

comment = "BAGUS, TERUS BELAJAR DAN BERLATIH....!!!!"; 
 

} else if ((Number (correct)<=2) and (Number (correct)>=1)){ 

comment = "TINGKATKAN PRESTASIMU...!!!!"; 

} else if ((Number (correct)==0)) { 
 

comment = "KAMU HARUS LEBIH GIAT LAGI BELAJAR...!!!!"; 
 

} 
 

47. Klik File > Save. 
 

48. Lakukan Test Movie. 
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I. Halaman Simulasi Sifat 
 

1. Buka file Sifat yang ada di folder Simulasi. Terdapat layer trapesium yang 

menggunakan 140 frame. 

2. Buka Library Panel. Klik and drag Simbol Tulisan dan Trapesium ke stage. 

Atur propertiesnya, untuk simbol Tulisan X = 306.1, Y = 198.8. Untuk simbol 

Trapesium X =419.1, Y = 264.3. 

3. Buat layer baru di bawah layer Trapesium, beri nama Sudut A. 
 

4. Klik and drag Simbol sudut A ke stage. Atur propertiesnya X = 392.8, Y = 

392.1. 

5. Klik frame 20 , klik Insert > Keyframe. Klik simbol sudut A di stage pada posisi 

frame 20, tekan tombol Delete pada keyboard. 

6. Klik and drag Simbol A ke stage. Atur propertiesnya X = 392.8, Y = 392.1. 
 

7. Klik frame 40, Insert > Keyframe. Klik simbol A dan ubah propertiesnya menjadi 
 

X = 357.8, Y = 392.1. 
 

8. Klik frame 20, Insert > Create Motion Tween. 
 

9. Klik frame 60, Insert > Keyframe. Klik simbol A dan ubah propertiesnya menjadi 

X = 358.8, Y = 245.1. 

10. Klik frame 40, Insert > Create Motion Tween. 
 

11. Klik frame 80, Insert > Keyframe. Klik simbol A dan ubah propertiesnya menjadi 
 

X = 461.8, Y = 245.1. 
 

12. Buat layer baru di bawah layer sudut A, beri nama sudut C. 
 

13. Klik and drag Simbol sudut C ke stage. Atur propertiesnya X = 546.4, Y = 

259.6. 

14. Klik frame 81 , klik Insert > Keyframe. Klik simbol sudut A di stage pada posisi 

frame 81, tekan tombol Delete pada keyboard. 

15. Klik and drag Simbol C ke stage. Atur propertiesnya X = 546.4, Y = 259.6. 
 

16. Klik frame 99, Insert > Keyframe. Klik simbol C dan ubah propertiesnya menjadi 

X = 646.4, Y = 259.6. 

17. Klik frame 81, Insert > Create Motion Tween. 
 

18. Klik frame 119, Insert > Keyframe. Klik simbol C dan ubah propertiesnya 

menjadi X = 646.4, Y = 406.6. 

19. Klik frame 99, Insert > Create Motion Tween. 
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20. Klik frame 140, Insert > Keyframe. Klik simbol C dan ubah propertiesnya 

menjadi X = 581.4, Y = 406.6. 

21. Klik frame 119, Insert > Create Motion Tween. 
 

22. Klik frame 140, buka Action panel, beri script stop();. 
 

23. Buat layer baru di bawah layer sudut C, beri nama Kesimpulan. 
 

24. Klik frame 140, Insert > Keyframe. 
 

25. Klik and drag Simbol Kesimpulan ke stage. Atur propertiesnya X = 242.4, Y = 

467.0. 

26. Klik File > Save. 
 

27. Lakukan Test Movie. 
 

 

J. Halaman Simulasi Luas. 
 

1. Buka file simulasi Luas yang ada di folder simulasi. Terdapat layer Judul yang 

menggunakan 75 frame. Frame 1 berisi simbol judul. 

2. Buat layer baru di bawah layer Judul, beri nama layer Trapesium. 
 

3. Klik and drag Simbol Trapesium ke stage, atur propertiesnya X = 225.1, Y = 

272.6. 

4. Buat layer baru di bawah layer Trapesium, beri nama segitiga. 
 

5. Klik and drag Simbol segitiga ke stage. Atur propertiesnya X = 286.6, Y = 

286.1. 

6. Klik frame 25, Insert > Keyframe. 
 

7. Klik frame 50, Insert > Keyframe. Ubah propertiesnya menjadi X = 322.6, Y = 

286.1. 

8. Klik frame 25, Insert > Create Motion Tween. 
 

9. Buat layer baru di bawah layer Segitiga, beri nama Rumus. 
 

10. Klik frame 75, Insert > Keyframe. 
 

11. Klik and drag Simbol Rumus dan Simbol Kesimpulan ke stage. Atur properties 

simbol Rumus X = 463.0, Y = 299.3, properties simbol Kesimpulan X = 203.1, Y 

= 485.1. 
 

12. klik frame 75, buka Action panel dan berikan script stop();. 
 

13. Klik File > Save. 
 

14. Lakukan Test Movie. 
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K. Publish Movie. 
 

1. Buka file Definisi yang ada di folder Trapesium (halaman utama definisi). 
 

2. Klik File > Publish Setting. 
 

3. Klik kotak Windows Projector (.exe). 
 

4. Klik Publish. 
 

5. Klik OK. 
 

6. Buka Windows Explorer. Buka folder Trapesium, terdapat tiga file dengan nama 

definisi, yaitu Definisi.fla, Definisi.swf, dan Definisi.exe. 

File Definisi.exe digunakan dalam membuat CD autorun, file Definisi .exe 

merupakan file yang terlihat pertama kali setelah CD dimasukkan ke CD 

Drive 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 8.12. Publish Setting 
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BAB 8 
 

CD AUTORUN 
 

 

A. Membuat File Autorun 
 

1. Klik Start > Program > Accessoris > Notepad. 
 

2. Ketikan 
 

[AUTORUN] 
 

OPEN = Definisi.exe 
 

3. Klik File > Save As. Beri nama AUTORUN.INF. Simpan di folder yang sama 

dengan file Definisi.exe. 

File AUTORUN .INF harus berada pada folder yang sama dengan file yang 

bertipe *.exe. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 9.1. Letak File AUTORUN.INF 
 

 

B. Burning CD 
 

Program Nero yang akan dibahas dalam bab ini adalah Program Nero Express. 

Program ini digunakan untuk memindahkan atau mengcopy file-file di komputer ke 

CD. Proses pemindahan ini sering disebut dengan proses membakar CD (burning). 
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Langkah yang dijelaskan dalam bab ini adalah langkah untuk memindahkan file ke 

CD dengan format autorun, langkah ini sama dengan langkah untuk memindahkan 

file ke CD dengan format Install Setup karena hanya memindahkan file saja. 

Langkah-langkahnya adalah sebagai berikut : 

1. Masukkan CD kosong ke dalam CD Writer. 
 

2. Klik Program > Nero > Nero StarSmart. 
 

3. Klik Data > Make Data Disk. 
 

4. Klik tombol Add. 
 

5. Buka folder Trapesium dan tekan tombol Crtl + A. 
 

6. Klik Add dan klik Finished.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Gambar 9.2. Select Files and Folders 
 

7. Tekan tombol Crtl dan klik file yang bertipe *.fla kemudian klik Delete 
 

8. Double klik folder Simulasi dan ulangi langkah 7. 
 

9. Double klik folder Tutorial dan ulangi langkah 7. 
 

10. Setelah semua file dipindahkan ke kotak dialog Disc Contents klik Next. 
 

11. Dalam kotak dialog Final Burn Setting, beri nama CD di kotak Dics Name, pilih 

kecepatan CD ROM pada kotak Writing Speed, pilih Allow files to be added later. 

12. Klik Burn. 
 

13. Setelah proses burning selesai klik OK. 
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